Database Failure
Incident Report for Car Throttle
Resolved
The database has been restored from a backup. The platform is now stable.
Posted almost 2 years ago. Sep 21, 2015 - 20:29 BST
Investigating
We are currently dealing with an issue with our master database.
Posted almost 2 years ago. Sep 21, 2015 - 16:48 BST