Client Version Update Failure
Incident Report for Car Throttle
Resolved
This incident has been resolved.
Posted over 2 years ago. Jun 10, 2015 - 23:56 BST
Identified
The issue has been identified and a fix is being implemented.
Posted over 2 years ago. Jun 10, 2015 - 23:50 BST